We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 14:48 PDT
Monitoring
We experienced temporary connectivity issues due to an outage from one of our upstream network providers. Things should be operational, but we're monitoring the situation!
Posted Jul 17, 2020 - 14:40 PDT
This incident affected: Polymail Apps (iOS, web, and desktop), Website (Landing Page), and Help & Support Site.