iCloud Service Degradation

Incident Report for Polymail

Resolved

iCloud users should now be able to access their accounts as Apple has resolved the issue. Thanks!

https://www.apple.com/support/systemstatus/
Posted Jun 02, 2020 - 18:21 PDT

Investigating

Users may not be able to access their iCloud accounts due to an ongoing service outage from Apple/iCloud services.

More information here. https://www.apple.com/support/systemstatus/
Posted Jun 02, 2020 - 17:17 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).