iCloud Sign in Errors
Incident Report for Polymail
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 15:22 PDT
Monitoring
A fix has been implemented and we're monitoring the issue!

Users should now be able to sign back into their iCloud accounts through Polymail. Thanks for the patience! 💌
Posted Jun 10, 2020 - 15:21 PDT
Update
We are continuing to investigate this issue.
Posted Jun 10, 2020 - 14:10 PDT
Investigating
We're currently investigating issues affecting iCloud Sign in.

Affected users may be seeing a prompt to reauthorize their iCloud accounts and may not be able to sign into their iCloud accounts through Polymail.
Posted Jun 10, 2020 - 14:09 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).