iCloud Connectivity Issues due to Apple Service Outage

Incident Report for Polymail

Resolved

Apple has fixed their outage and users should be able to sign into their iCloud accounts in Polymail
Posted Aug 05, 2020 - 12:00 PDT

Identified

iCloud services are currently down due to an outage from Apple. Users with connected iCloud accounts may see sync errors, and the inability to sign in.

https://www.apple.com/support/systemstatus/
Posted Aug 05, 2020 - 10:43 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).