Polymail is undergoing routine maintenance
Incident Report for Polymail
Resolved
We’re all good, maintenance done! Have a great night!
Posted Oct 10, 2024 - 19:33 PDT
Identified
Hi friends, we’ve started planned maintenance of Polymail’s database. We should be back up in approx. 30 min.
Posted Oct 10, 2024 - 19:01 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).