Degraded Service - Sync Issues
Incident Report for Polymail
Resolved
This incident has been resolved.
Posted Apr 01, 2022 - 09:20 PDT
Update
A significant subset of users experienced sync issues. We apologize to all who are affected by the disruption. The issue has been resolved.
Posted Apr 01, 2022 - 08:45 PDT
Investigating
A significant subset of users experienced sync issues. We apologize to all who are affected by the disruption. The issue has been resolved.
Posted Apr 01, 2022 - 08:45 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).