Polymail Webapp Outage
Incident Report for Polymail
Resolved
The issue has been resolved, all systems should be operational now!
Posted May 18, 2021 - 19:29 PDT
Investigating
We're currently investigating an issue that is causing connection issues for Polymail users on the Polymail client. Users may see delays when logging in, sending or receiving emails.
Posted May 18, 2021 - 18:24 PDT
This incident affected: Polymail Apps (iOS, web, and desktop).